Lottie Working in Anima and localhost but doesn't display when I deploy with Netlify

Hey everyone.

I recently created a design in figma and added a lottiefile to the design using the anima figma plugin. The lottie displays correctly and animates in both Anima and when I run locally. But when I deploy it through netlify the lottie no longer displays. If I open inspector I can see the lottieplayer code is there but the lottieplayer component dimensions are 0x0.

Any ideas?

Do I need to do anything other than add the lottie through the figma plugin such as install additional packages?


Hey @willbrettdesign thanks for writing! Would you mind sharing your Netlify link here so that we can check it out? Thanks :pray:t3:

Hi Shira,

Here is the link.


Hi Shira,

Here is the link: https://63375f392a2ae5006485d051--willbrettdesign-react.netlify.app/


Hey Shira,

I’ve tried to share the link but it keeps getting flagged.

Can you email it to us instead, support@animaapp.com? Thanks!

Any update on this? I sent an email 8days ago but no response yet. Thanks :slight_smile:

Hey Will! Sorry about that, I was actually just emailing you asking for your Figma file which should help us get to the bottom of this issue. Rest assured, we’re on it!