Stuck on "analyzing Storybook" -> "Something went wrong" error

Trying to test Anima for the first time. I’ve worked through the Anima CLI guide and successfully synced from my local Storybook on that side. However, when I go to open the Figma plugin, I’m stuck. After choosing components, I’ll get to the “Analyzing Storybook” screen and it will just hang there for about 10 minutes.

Eventually I’ll get an error that reads “Something went wrong with the connection. Please try again.”
(I can’t include a screenshot of this, because I am limited to one image upload per post…)

I have tried restarting Figma multiple times, closing/reopening the plugin, rerunning the sync command in the CLI - nothing works. Not a great start!

1 Like

Hi @bradenfrazer , thanks for reporting. Please, try creating a new project in the plugin and syncing the library from Storybook to the new project. If the issue persists, please, send us the link to the library.

Hi Jenya,

I’m not sure what exactly you mean by “create a new project in the plugin”, I haven’t seen any options for a new project in the plugin. When I open the plugin, the only options that I have are for Components, or Dseign Tokens (listed as coming soon), or I can switch to “Design to code” mode (not the feature I’m looking for). There are no options for new projects, and it seems within Figma there’s not a way to remove the plugin either, if I were to try to reinstall it.

I did try a completely new React project yesterday with a single component, and after spinning all of it up with Storybook and getting it running, I attempted the same CLI commands too to no avail. I had the same experience as I noted before.

Of course, I am using the CLI commands as they appear to be the option for users that do not have a public library. As my library is not public, I can’t send you a link to it.

It is a little frustrating that there are no error codes to understand why or where it’s failing or have any other way to debug what is going on here. After spending a few days on this, I think I am just going to move on from trying the product, unless you have any further suggestions.

Hi @bradenfrazer, thanks for the details. Please, restart Anima plugin by logging out and logging in.
Click :gear: under your profile icon and log out:


Let me know if you still can’t sync your library.

Hi Jenya,

I have followed your instructions to log out and log in again, but when visiting the Components section in the plugin, I still receive the infinite sync error as I noted in my first post.

Hi @bradenfrazer, could you send us a link to the library in a private message here or by email (